A - The Suspects

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1
题解:0是感染者,和0一组的都是怀疑对象。即找到哪些人和0在一个集合里,就是看谁的根和0的根一样。

#include<cstdio>
#include<cstring>

using namespace std;

const int maxn = (int)30000 + 10;
int pre[30000];
int a[30000];
//int init(int n){
//
//}
int find(int x){
    return pre[x]==x?x:pre[x]=Find(pre[x]);
}
void merge(int x,int y){
    int fx = find(x);
    int fy = find(y);
    if(fx != fy){
        pre[fy] = fx;
    }
}   
int n,m;
int k;
int sum;
int main(){

    while(~scanf("%d%d",&n,&m) && (n||m)){
        for(int i = 0;i<n;i++) pre[i] = i;
        sum = 0;
        while(m--){
    //      memset(a,0,sizeof(a));
            scanf("%d",&k);
            scanf("%d",&a[0]);
            for(int j = 1;j<k;j++){
                scanf("%d",&a[j]);
                merge(a[0],a[j]);
            }
        }
        for(int i=0;i<n;i++)
            if(find[i] == pre[0])
                sum++;
        printf("%d\n",sum);
    }   
}

猜你喜欢

转载自blog.csdn.net/Lj_victor/article/details/81706278
今日推荐