The Suspects

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

题解:有很多组学生,在同一个组的学生经常会接触,也会有新的同学的加入。但是SARS是很容易传染的,只要在改组有一位同学感染SARS,那么该组的所有同学都被认为得了SARS。现在的任务是计算出有多少位学生感染SARS了。假定编号为0的同学是得了SARS的。

代码如下:

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stack>
#include<queue>
#include<deque>
using namespace std;
typedef long long ll;
int a[30005];
int num[30005];//记录人数
int findx(int x)
{
	int r=x;
	while(r!=a[r])
	{
		r=a[r];
	}
	return r;
}
void fff(int x,int y)
{
	int fx=findx(x);
	int fy=findx(y);
	if(fx!=fy)
	{
		if(num[fx]>=num[fy])
		{
			a[fy]=fx;
			num[fx]+=num[fy];
		}
		else
		{
			a[fx]=fy;
			num[fy]+=num[fx];
		}
	}
}
int main()
{
	int m,n;
	while(cin>>m>>n)
	{
		if(m==0&&n==0)
			break;
		for(int i=0;i<m;i++)
        {
            a[i]=i;
            num[i]=1;
        }
		while(n--)
		{
			int b,c;
			cin>>b>>c;
			b--;
			while(b--)//查找每一组与首人的关系
			{
				int d;
				cin>>d;
				fff(c,d);
			}
		}
		cout<<num[a[0]]<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/baiyi_destroyer/article/details/80487686
今日推荐