dfs(判断可达性)

数据结构实验之图论四:迷宫探索
Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
有一个地下迷宫,它的通道都是直的,而通道所有交叉点(包括通道的端点)上都有一盏灯和一个开关;请问如何从某个起点开始在迷宫中点亮所有的灯并回到起点?
Input
连续T组数据输入,每组数据第一行给出三个正整数,分别表示地下迷宫的结点数N(1 < N <= 1000)、边数M(M <= 3000)和起始结点编号S,随后M行对应M条边,每行给出一对正整数,表示一条边相关联的两个顶点的编号。

Output
若可以点亮所有结点的灯,则输出从S开始并以S结束的序列,序列中相邻的顶点一定有边,否则只输出部分点亮的灯的结点序列,最后输出0,表示此迷宫不是连通图。
访问顶点时约定以编号小的结点优先的次序访问,点亮所有可以点亮的灯后,以原路返回的方式回到起点。

Sample Input
1
6 8 1
1 2
2 3
3 4
4 5
5 6
6 4
3 6
1 5
Sample Output
1 2 3 4 5 6 5 4 3 2 1
Hint

Source
xam

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int e[1010][1010],book[1010],b[1010];
int sum,p;
void dfs(int c,int n)
{
    if(sum==n)return ;
    for(int i=1;i<=n;i++)
    {
        if(e[c][i]==1&&book[i]==0)
        {
            book[i]=1;
            b[p++]=i;//这里已经把i存进去了
            sum++;
            dfs(i,n);
            b[p++]=c;//这里存的话是存c;
        }
    }
}
int main()
{
    int t,n,m,s;
    scanf("%d",&t);
    while(t--)
    {
        sum=0,p=0;
        memset(e,0,sizeof(e));
        memset(book,0,sizeof(book));
        scanf("%d%d%d",&n,&m,&s);
        while(m--)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            e[x][y]=1;
            e[y][x]=1;
        }
        book[s]=1;
        sum++;
        b[p++]=s;
        dfs(s,n);
        for(int i=0;i<p;i++)
        {
            if(i==0)printf("%d",b[i]);
            else printf(" %d",b[i]);
        }
        if(p!=n*2-1)printf(" 0");
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/BHliuhan/article/details/81672536