HDU 1020 Encoding(字符统计)

Encoding
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 54048 Accepted Submission(s): 24021

Problem Description
Given a string containing only ‘A’ - ‘Z’, we could encode it using the following method:

  1. Each sub-string containing k same characters should be encoded to “kX” where “X” is the only character in this sub-string.

  2. If the length of the sub-string is 1, ‘1’ should be ignored.

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only ‘A’ - ‘Z’ and the length is less than 10000.

Output
For each test case, output the encoded string in a line.

Sample Input
2
ABC
ABBCCC

Sample Output
ABC
A2B3C

#include<bits/stdc++.h>
using namespace std;
struct node
{
    int pos;
    char e;
    int cnt;
}p[10005];
bool cmp(node p1,node p2)
{
    return p1.pos<p2.pos;
}
int main()
{
    int n;cin>>n;
    while(n--)
    {
        char s[10005];
        scanf("%s",s);
        int len=strlen(s);
        int ans=0;
        memset(p,0,sizeof(p));
        p[0].pos=0;p[0].e=s[0];
        p[0].cnt++;
        for(int i=1;i<len;i++)
        {
            if(s[i]==s[i-1])
                p[ans].cnt++;
            else
            {//cout<<"**"<<endl;
                p[++ans].pos=i;
                p[ans].e=s[i];
                p[ans].cnt++;
            }
        }
        for(int i=0;i<=ans;i++)
        {
            if(p[i].cnt==1)
                cout<<p[i].e;
            else
                cout<<p[i].cnt<<p[i].e;
        }
        cout<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/a17865569022/article/details/81457754