杭电ACM-1020 Encoding

                                              Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 56525    Accepted Submission(s): 25233

 

Problem Description

Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

 

Input

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

 

Output

For each test case, output the encoded string in a line.

 

Sample Input

2

ABC

ABBCCC

Sample Output

ABC

A2B3C

水题,简单的字符串处理,题目大意:将类似于AAABBCC变成3A2B2C.

就是说把连续相同的字符变成 个数 + 字母 的形式,1个时不显示个数。

#include<bits/stdc++.h>
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
char b[10005];
int main ()
{
	int n,count,len;
	cin>>n;
	for(int i=0;i<n;i++)
	{   
		cin>>b;
        len=strlen(b);
		for(int j=0;j<len;j++)
		{
			count=1;
                while(b[j]==b[j+1])
				{
					count++;
					j++;
				}
			    if(count>1)
			   {
				    cout<<count<<b[j];
			   }
			    else
				    cout<<b[j];
		}
		cout<<endl;
	}
	return 0;
}

DP做废了,练练简单题

猜你喜欢

转载自blog.csdn.net/qq_36791466/article/details/84137506