【HDU - 6182】【A Math Problem 】

 

Problem Description

You are given a positive integer n, please count how many positive integers k satisfy kk≤n .

 

Input

There are no more than 50 test cases.

Each case only contains a positivse integer n in a line.

1≤n≤1018

 

Output

For each test case, output an integer indicates the number of positive integers k satisfy kk≤n in a line.

 

Sample Input

 

1 4

 

Sample Output

 

1 2

 

Source

2017ACM/ICPC广西邀请赛-重现赛(感谢广西大学)

解题思路:思考后会发现15^15就已经会爆long long 了,所以直接暴力求解1-15中符合条件的就欧克

ac代码:

#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring> 
using namespace std;
typedef long long ll;
ll n;
int k;
ll ksm(ll a,ll  b)
{
	ll res=1;
	while(b)
	{
		if(b&1) 
			res=res*a;
		a=a*a;
		b>>=1;
	}
	return  res;
}
int main()
{
	while(scanf("%lld",&n)!=EOF)
	{
		int ans=0;
		for(ll i=1;i<=15;i++)
		{
			if(ksm(i,i)>n)
				break; 
			ans++; 
		}
		printf("%d\n",ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42505741/article/details/81584089