poj 2250 打印字符串(最长公共子序列)

Description

In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germany will fulfill the criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,...) that it is really hard to choose what to do. 

Therefore the German government requires a program for the following task: 
Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what both people have in mind). 

Your country needs this program, so your job is to write it for us.

Input

The input will contain several test cases. 
Each test case consists of two texts. Each text is given as a sequence of lower-case words, separated by whitespace, but with no punctuation. Words will be less than 30 characters long. Both texts will contain less than 100 words and will be terminated by a line containing a single '#'. 
Input is terminated by end of file.

Output

For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline character.

Sample Input

die einkommen der landwirte
sind fuer die abgeordneten ein buch mit sieben siegeln
um dem abzuhelfen
muessen dringend alle subventionsgesetze verbessert werden
#
die steuern auf vermoegen und einkommen
sollten nach meinung der abgeordneten
nachdruecklich erhoben werden
dazu muessen die kontrollbefugnisse der finanzbehoerden
dringend verbessert werden
#

Sample Output

die einkommen der abgeordneten muessen dringend verbessert werden

能力不够,这题提交了好几次都是wa.一开始思路不对,关注点集中在公共而忽略了最长,后来发现每次都找相同的单词却不一定最长。便用dp。先正序搜索一遍最长公共子序列的长度并做上相应的标记,再反向依照标记搜索标记路径中相等的字符串。做到了这里我还是wa,英语渣渣把每个单词空一格最后一个单词换行看成了每两个单词间空一格。卒 ┓(;´_`)┏

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<string>
using namespace std;
string x[110],y[110];
int dp[110][110];
int mark[110][110];
int main()
{
        int leng1=0,leng2=0;
        int k=1;
        while(cin>>x[1]&&x[1]!="#")
        {
                k++;leng1++;
                while(cin>>x[k]&&x[k++]!="#")
                {
                        leng1++;
                }
                k=1;
                while(cin>>y[k]&&y[k]!="#")
                {
                        k++;leng2++;
                }

        int i,j;
        memset(dp,0,sizeof(dp));
        memset(mark,0,sizeof(mark));
        for(i=1;i<=leng1;i++)
            for(j=1;j<=leng2;j++)
        {
                if(x[i]==y[j])
                {
                        dp[i][j]=dp[i-1][j-1]+1;
                }
                else if(dp[i-1][j]>dp[i][j-1])
                {
                        dp[i][j]=dp[i-1][j];mark[i][j]=-1;
                }
                else
                {
                        dp[i][j]=dp[i][j-1];mark[i][j]=1;
                }
        }
      k=dp[leng1][leng2];int p=0;string h[50];i=leng1;j=leng2;
      while(p<k)
      {
              if(mark[i][j]==0)
              {
                      h[p++]=x[i];i--;j--;
              }
              else if(mark[i][j]==1)
              {
                      j--;
              }
              else
              {
                      i--;
              }
      }
      for(i=k-1;i>=0;i--)
        cout<<h[i]<<' ';
        k=1;leng1=0;leng2=0;
     printf("\n");

}
      return 0;
}

猜你喜欢

转载自blog.csdn.net/intelligentgirl/article/details/81449957