hdu1217Arbitrage (Bellman)

Arbitrage

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9624    Accepted Submission(s): 4393

Problem Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

 

3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0

Sample Output

 

Case 1: Yes Case 2: No

Source

University of Ulm Local Contest 1996

 题意:国家之间存在汇率,存在一种依靠通过汇率赚取财富的的方式就输出Yes,否则输出No。

思路:最短路径的做法,尽可能使自己的钱转换成该国家的货币多,如果存在这样的环路,则可以赚取财富,输出Yes。通过环我联想到了最短路径的Bellman算法,如果存在环,松弛的次数会超过V-1次。否则不存在这样的环。

AC代码:

#include <cstdio>
#include <algorithm> 
#include <cstring>
#include <map>
#include <iostream>
using namespace std;

const int MAX_E  = 1000;
const int MAX_V = 33;
const int INF = 0x3f3f3f3f;
struct node{
    int from;
    int to;
    double cost;
}es[MAX_E*4];
int cae=0;
int V,E;
double d[MAX_V];

map<string,int> mp;

bool bellman(int s){
    //fill(d,d+MAX_V,-2);
    for(int i=0;i<MAX_V;i++){
        d[i]=-99999999;
    }
    d[s]=1;
    for(int j=0;j<V;j++){
        bool update=false;
        for(int i=0;i<E;i++){
            
            if(d[es[i].from]!=-99999999 && d[es[i].to] < d[es[i].from]*es[i].cost){
                if(j==V-1){
                    return true;
                }
            
                d[es[i].to]=d[es[i].from]*es[i].cost;
    
                update=true;
            
            }
        }
        if(!update) break;
    }
    return false;
}

void solve(){
    bool flag=false;
    for(int i=0;i<V;i++){
            
        if(bellman(i)){
        
            flag=true;
            
            break;
        }
    }
    if(flag){
        cout << "Case " << ++cae << ": Yes" << endl;
    }else{
       cout << "Case " << ++cae << ": No" << endl;
    }
}
int main(){
    ios::sync_with_stdio(false);
    while(cin>> V && V){
        mp.clear();
        for(int i=0;i<V;i++){
            string str;
            cin >> str;
            mp[str]=i;
        }
        cin >> E;
        map<string,int>::iterator it;
        for(int i=0;i<E;i++){
            string str1,str2;
            double cost;
            cin >> str1 >> cost >> str2;
            it=mp.find(str1);
            es[i].from=it->second;
            it=mp.find(str2);
            es[i].to=it->second;
            es[i].cost=cost;
        }
        
        solve();
        
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Rainbow_storm/article/details/80719839