【POJ 1837】Balance(DP)

Balance
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions:16036   Accepted: 10090

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

题意就是有一个天平,有C个挂钩,你知道每个挂钩距离中心平衡点的距离,左边为负,右边为正,再给你G个钩码的质量,问你有多少中方法使得天平平衡。

我们用dp[i-1][j]来表示放上i-1个钩码平衡度为j的方法数,根据题意范围,j为0的时候平衡,此时7500>=j>=-7500,但是下标不能是负数,因此,我们进行一个转化,令0=<j<=15000,则j=7500的时候达到平衡状态,令dp[0][7500]=1(一个也没放的时候肯定平衡,方法数就一种),能够改变平衡度的只有力矩w[i]*c[k];故下一个状态为dp[i][j+w[i]*c[k]]的方法数等于上一个状态数方法的总和。

/*有一个天平,天平左右两边各有若干个钩子,总共有C个钩子,有G个钩码,求将钩码全部挂到钩子上使天平平衡的方法的总数。

其中可以把天枰看做一个以x轴0点作为平衡点的横轴
*/
#include<iostream>
#include<string.h> 
#include<algorithm>
using namespace std;
#define MAXN 15000
int dp[20][MAXN];
int w[30];
int c[30];
int n,m;
int main()
{
	cin>>n>>m;
	for(int i=1;i<=n;i++) cin>>c[i];
	for(int i=1;i<=m;i++) cin>>w[i];
	memset(dp,0,sizeof(dp));
	dp[0][7500]=1;
	for(int i=1;i<=m;i++)
	{
		for(int j=0;j<=MAXN;j++)
		{
			if(dp[i-1][j])//小优化 
			{
				for(int k=1;k<=n;k++)
				{
					dp[i][j+w[i]*c[k]]+=dp[i-1][j];
				}
			}
		}
	}
	cout<<dp[m][7500]<<endl;
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/duanghaha/article/details/80489229