Restoring Road Network 反证最短路

问题 C: Restoring Road Network

时间限制: 1 Sec  内存限制: 128 MB
提交: 438  解决: 89
[提交] [状态] [讨论版] [命题人:admin]

题目描述

In Takahashi Kingdom, which once existed, there are N cities, and some pairs of cities are connected bidirectionally by roads. The following are known about the road network:
People traveled between cities only through roads. It was possible to reach any city from any other city, via intermediate cities if necessary.
Different roads may have had different lengths, but all the lengths were positive integers.
Snuke the archeologist found a table with N rows and N columns, A, in the ruin of Takahashi Kingdom. He thought that it represented the shortest distances between the cities along the roads in the kingdom.
Determine whether there exists a road network such that for each u and v, the integer Au,v at the u-th row and v-th column of A is equal to the length of the shortest path from City u to City v. If such a network exist, find the shortest possible total length of the roads.

Constraints
1≤N≤300
If i≠j, 1≤Ai,j=Aj,i≤109.
Ai,i=0

输入

Input is given from Standard Input in the following format:
N
A1,1 A1,2 … A1,N
A2,1 A2,2 … A2,N

AN,1 AN,2 … AN,N
 

输出

If there exists no network that satisfies the condition, print -1. If it exists, print the shortest possible total length of the roads.

样例输入

3
0 1 3
1 0 2
3 2 0

样例输出

3

提示

The network below satisfies the condition:
City 1 and City 2 is connected by a road of length 1.
City 2 and City 3 is connected by a road of length 2.
City 3 and City 1 is not connected by a road.

这个题一开始读了很久没理解题意,后来好不容易觉得自己读懂了(给点之间的距离,求最短路),赶紧拿floyd开始写,写了半天觉得怪怪的,输出的矩阵里和输入一模一样,一开始怀疑代码有bug,后来de了半天也没发现,只好重新读题

最后才搞明白输入的数据是最短路的矩阵,证明这个最短路是不是合法(我是这样理解的,如果是错的,希望指出),如果是,输出最短的边距离,否则输出-1

大概Floyd思想,如果mapp[i][j]>mapp[i][k]+mapp[k][j],则证明不合法

                          如果mapp[i][j]=mapp[i][k]+mapp[k][j],那么i到j可以不需要k这个中间点

代码:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxx=500;
const int INF=1e9+100;
const int MOD=1e9+7;
int n;
ll mapp[maxx][maxx];
int main()
{
    scanf("%d",&n);
    for(int i=1; i<=n; i++){
        for(int j=1; j<=n; j++){
            scanf("%lld",&mapp[i][j]);
        }
    }
    ll ans=0;
    int flag;
    for(int i=1; i<=n; i++){
        for(int j=1; j<=n; j++){
            if(i==j)  continue;
            flag=1;
            for(int k=1; k<=n; k++){
                if(i==k || j==k) continue;
                if(mapp[i][j]>mapp[i][k]+mapp[k][j]){
                    cout<<"-1"<<endl;
                    return 0;
                }
                if(mapp[i][j]==mapp[i][k]+mapp[k][j]){
                    flag=0;
                }
            }
            if(flag) ans+=mapp[i][j];
        }
    }
    printf("%lld\n",ans/2);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/renzijing/article/details/81302199