Restoring Road Network

问题 C: Restoring Road Network

时间限制: 1 Sec  内存限制: 128 MB
提交: 981  解决: 220
[提交] [状态] [讨论版] [命题人:admin]

题目描述

In Takahashi Kingdom, which once existed, there are N cities, and some pairs of cities are connected bidirectionally by roads. The following are known about the road network:
People traveled between cities only through roads. It was possible to reach any city from any other city, via intermediate cities if necessary.
Different roads may have had different lengths, but all the lengths were positive integers.
Snuke the archeologist found a table with N rows and N columns, A, in the ruin of Takahashi Kingdom. He thought that it represented the shortest distances between the cities along the roads in the kingdom.
Determine whether there exists a road network such that for each u and v, the integer Au,v at the u-th row and v-th column of A is equal to the length of the shortest path from City u to City v. If such a network exist, find the shortest possible total length of the roads.

Constraints
1≤N≤300
If i≠j, 1≤Ai,j=Aj,i≤109.
Ai,i=0

输入

Input is given from Standard Input in the following format:
N
A1,1 A1,2 … A1,N
A2,1 A2,2 … A2,N

AN,1 AN,2 … AN,N
 

输出

If there exists no network that satisfies the condition, print -1. If it exists, print the shortest possible total length of the roads.

样例输入

3
0 1 3
1 0 2
3 2 0

样例输出

3

提示

The network below satisfies the condition:
City 1 and City 2 is connected by a road of length 1.
City 2 and City 3 is connected by a road of length 2.
City 3 and City 1 is not connected by a road.

思路:找到从一个点到另一个点的直接距离和间接距离如果直接距离小于间接距离那么就输出-1否则就加上直接和间接距离,如果直接距离和间接距离相同的话就减去一个直接距离

#include<bits/stdc++.h>
using namespace std;

#define ll long long
ll n,a[305][305];
int main()
{
    cin>>n;
    ll i,j;
    bool flag=false;
    for(i=1; i<=n; i++)
        for(j=1; j<=n; j++)
            scanf("%lld",&a[i][j]);
    ll ans=0;
for(i=1;i<=n;i++)
{
    for(j=1;j<=i;j++)
    {flag=false;
        for(int k=1;k<=n;k++)
        {
            if(a[i][j]>a[i][k]+a[k][j])
            {
                printf("-1\n");
                exit(0);
            }
            if(a[i][j]==a[i][k]+a[k][j]&&i!=k&&j!=k)
                {//cout<<i<<" "<<j<<" "<<k<<" "<<a[i][j]<<endl;
                    flag=true;
                }
        }
        if(!flag)
                {ans+=a[i][j];
                //cout<<i<<"  "<<j<<endl;
                }
    }
}
cout<<ans<<"\n";
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wearegamer/article/details/81664585