浙江大学月赛 District Division

District Division


Time Limit: 1 Second      Memory Limit: 65536 KB      Special Judge


Ezio learned a lot from his uncle Mario in Villa Auditore. He also made some contribution to Villa Auditore. One of the contribution is dividing it into many small districts for convenience of management. If one district is too big, person in control of this district would feel tiring to keep everything in order. If one district is too small, there would be too many districts, which costs more to set manager for each district.

There are  rooms numbered from 1 to  in Villa Auditore and  corridors connecting them. Let's consider each room as a node and each corridor connecting two rooms as an edge. By coincidence, Villa Auditore forms a tree.

Ezio wanted the size of each district to be exactly , which means there should be exactly  rooms in one district. Each room in one district should have at least one corridor directly connected to another room in the same district, unless there are only one room in this district (that is to say, the rooms in the same district form a connected component). It's obvious that Villa Auditore should be divided into  districts.

Now Ezio was wondering whether division can be done successfully.

Input

There are multiple test cases. The first line of the input contains an integer  (about 10000), indicating the number of cases. For each test case:

The first line contains two integers ,  (, ), indicating the number of rooms in Vally Auditore and the number of rooms in one district.

The following  lines each contains two integers ,  (), indicating a corrider connecting two rooms  and .

It's guaranteed that:

  •  is a multiple of ;

  • The given graph is a tree;

  • The sum of  in all test cases will not exceed .

Output

For each test case:

  • If the division can be done successfully, output "YES" (without quotes) in the first line. Then output  lines each containing  integers seperated by one space, indicating a valid division plan. If there are multiple valid answers, print any of them.

  • If the division cannot be done successfully, output "NO" (without quotes) in the first line.

Please, DO NOT output extra spaces at the end of each line, or your answer will be considered incorrect!

Sample Input

3
4 2
1 3
3 2
1 4
6 3
1 3
1 4
1 6
2 5
5 1
8 4
1 2
2 3
2 4
1 5
5 6
5 7
5 8

Sample Output

YES
1 4
2 3
NO
YES
4 3 2 1
5 6 7 8

题意:一棵树上有n个节点和n-1条边,问是否能将这棵树割成k个节点数相同的子树。

题解:保存树上所有子树的节点数,如果节点数是k的倍数的子树==n/k,则一定可以,否则就不可以,那么可以直接dfs找子树的节点的数量。

#include <bits/stdc++.h>
using namespace std;
struct tree
{
    int n;
    vector<int> a;
};
tree A[100005];
int B[100005];
bool vis[100005];
int findi(int i)
{
    if(!vis[i])
    {
        vis[i]=true;
        int t=1;
        for(int j=0;j<A[i].a.size();j++)
        {
            if(!vis[A[i].a[j]])
            t+=findi(A[i].a[j]);
        }
        return A[i].n=t;
    }
    return A[i].n;
}
int main()
{
    int t,n,k;
    int j,i,l,a,b;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        for(i=0;i<=n;i++){
            A[i].n=0;
            A[i].a.clear();
        }
        for(i=1;i<n;i++)
        {
            scanf("%d%d",&a,&b);
            A[a].a.push_back(b);
            A[b].a.push_back(a);
        }
        memset(vis,false,sizeof(vis));
        A[1].n=findi(1);
        l=n/k;
        j=0;
        for(i=1;i<=n;i++)
        {
            if(A[i].n%k==0)
            {
                B[j++]=i;
            }
        }
       
        if(j==l)
        {
            printf("YES\n");
            memset(vis,false,sizeof(vis));
            for(i=0;i<j;i++)
            {
                queue<int> T;
                T.push(B[i]);
                vis[B[i]]=true;
                while(!T.empty())
                {
                    a=T.front();
                    T.pop();
                    for(l=0;l<A[a].a.size();l++)
                    {
                        if((A[A[a].a[l]].n%k!=0)&&!vis[A[a].a[l]])
                        {
                            vis[A[a].a[l]]=true;
                            T.push(A[a].a[l]);
                        }
                    }
                    printf("%d",a);
                    if(!T.empty()) printf(" ");
                    else printf("\n");
                }
            }
        }
        else printf("NO\n");
    }
    return 0;
}


 

猜你喜欢

转载自blog.csdn.net/sudu6666/article/details/81281863