UVA - 725 ACM/ICPC Division

Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits 0 through 9 once each, such that the first number divided by the second is equal to an integer N, where 2 ≤ N ≤ 79. That is, abcde fghij = N where each letter represents a different digit. The first digit of one of the numerals is allowed to be zero.

Input

Each line of the input file consists of a valid integer N. An input of zero is to terminate the program.

Output

Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and, of course, denominator). Your output should be in the following general form:

xxxxx / xxxxx = N

xxxxx / xxxxx = N

.

.

In case there are no pairs of numerals satisfying the condition, you must write ‘There are no solutions for N.’. Separate the output for two different values of N by a blank line.

Sample Input

61

62

0

Sample Output

There are no solutions for 61.

79546 / 01283 = 62

#include <stdio.h>
int num(int shu);
void wei(int shu,int a[],int n);

int main()
{
	int n;
	int nn=0;
	while(scanf("%d",&n)!=EOF&&n)
	{
		int f=0;
		if(nn++>0)
		printf("\n");
		int i;
		for(i=1;i<=99999/n;i++)
		{
			int a,b;
			a=i*n;b=i;
			int numa,numb;
			numa=num(a);
			numb=num(b);
			int zi[10]={0};
			int mu[10]={0};
			wei(a,zi,numa);
			wei(b,mu,numb);
			int shu[10]={0};
			int j;
			for(j=0;j<5;j++)
				{
					shu[zi[j]]++;
					shu[mu[j]]++;
				}
			int flag=0;
			for(j=0;j<=9;j++)
				if(shu[j]>=2)
					flag=1;
			if(flag==0)
				{
					printf("%05d / %05d = %d\n",a,b,n);
					f=1;
					nn++;
				}
		}
		if(f==0)
			printf("There are no solutions for %d.\n",n);
	}
	return 0;
}

int num(int shu)
{
	int n=0;
	while(shu>0)
	{
		n++;
		shu=shu/10;
	}
	return n;
}

void wei(int shu,int a[],int n)
{
	int i;
	for(i=0;i<n;i++)
	{
		a[i]=shu%10;
		shu=shu/10;
	}
}

94736 / 01528 = 62

猜你喜欢

转载自blog.csdn.net/LLer_Dagu/article/details/81159250