UVa725----Division(枚举)

Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits 0 through 9 once each, such that the first number divided by the second is equal to an integer N, where 2 ≤ N ≤ 79. That is, abcde fghij = N where each letter represents a different digit. The first digit of one of the numerals is allowed to be zero. Input Each line of the input file consists of a valid integer N. An input of zero is to terminate the program. Output Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and, of course, denominator). Your output should be in the following general form: xxxxx / xxxxx = N xxxxx / xxxxx = N . . In case there are no pairs of numerals satisfying the condition, you must write ‘There are no solutions for N.’. Separate the output for two different values of N by a blank line. Sample Input 61 62 0 Sample Output There are no solutions for 61. 79546 / 01283 = 62 94736 / 01528 = 62

代码如下:  

方法枚举+打表法。

# include <stdio.h>
# include <string.h>
# include <math.h>
int main ()
{
 int n,m=0;
 while (scanf("%d",&n)==1&&n)
    {
     if (m++)printf ("\n"); // \n的个数要注意一下.
     int s[10],i,t,flag=1;
      for (i=1234;i<=98765/n;++i)  //枚举出所有的情况。
         {
         memset (s,0,sizeof(s)); // 数组清零。
           if (i<10000) s[0]=1;
           t=i;
            while (t>0)
                {
                  s[t%10]=1;
                  t=t/10;
                }
            t=i*n;
            while (t>0)
                {
                    s[t%10]=1;
                    t=t/10;
                }
            int j,sum=0;
            for (j=0;j<10;++j)
              sum=sum+s[j];1-9每一个位置都出现且只出现过一次,sum一定为10;
            if (sum==10)
              {
                  flag=0;
                  printf ("%05d / %05d = %d\n",i*n,i,n);
              }
         }
         if (flag) 
              printf ("There are no solutions for %d.\n",n);             
     }     
    return 0; //算法竞赛的话,一般都要加return 0;       
}

猜你喜欢

转载自blog.csdn.net/wcgwww/article/details/81155817
今日推荐