F - Wormholes POJ - 3259(spfa判负环)

Wormholes
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 60400   Accepted: 22564

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source


题意:John的农场里N块地,M条路连接两块地(无向)没走过一条路,消耗w秒,V个虫洞(有向),走过虫洞,时间会倒退w秒。判段,是否可以以N块地中的一块地为起点,找到一条路,使得时间可以不断的倒退。

思路:spfa判断是否有负环!

#include "iostream"
#include "queue"
#include "vector"
#include "cstring"
using namespace std;
const int Max=1e3+10;
int N,M,V;
int vis[Max],d[Max],cnt[Max];//分别记录是否已经入队,时间消耗,和入队次数
struct  edge//记录目的地和话费,如果是虫洞的话,花费为负数
{
    int to,cost;
};
vector<edge> G[Max];
bool spfa(int s)
{
    vis[s]=1;
    d[s]=0;
    queue<int> que;
    que.push(s);
    while(!que.empty()){
        int u=que.front();
        que.pop();
        vis[u]=0;
        for(int i=0;i<G[u].size();i++){
            edge e=G[u][i];
            if(d[e.to]>d[u]+e.cost){
                d[e.to]=d[u]+e.cost;
                if(vis[e.to]) continue;
                que.push(e.to);
                vis[e.to]=1;
                if(++cnt[e.to]>N&&d[e.to]<0) return 1;//一个最多可以进队N次,如果大于N说明有环,如果时间为负数,说明是负环
            }
        }
    }
    return 0;
}
int main()
{
    ios::sync_with_stdio(false);
    int t;
    cin>>t;
    while(t--){
        for(int i=0;i<Max;i++){G[i].clear(); vis[i]=0; d[i]=0xfffffff;cnt[i]=0;}
        int u,v,w;
        edge e;
        cin>>N>>M>>V;
        for(int i=0;i<M;i++){//普通道路
            cin>>u>>v>>w;
            e.to=v,e.cost=w;
            G[u].push_back(e);
            e.to=u;
            G[v].push_back(e);
        }
        for(int i=0;i<V;i++){//虫洞
            cin>>u>>v>>w;
            e.to=v;
            e.cost=-w;
            G[u].push_back(e);
        }
        int flag=0;
        for(int i=1;i<=N;i++)
            if(spfa(i)){flag=1;break;}
        if(flag)
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
}


猜你喜欢

转载自blog.csdn.net/qq_41874469/article/details/80598331