PAT A1007

读题很重要!很重要!很重要!

我一开始想成了输出最大字串开头结尾的序号。。。。

还有这道题O(n)时间复杂度也能做

1007 Maximum Subsequence Sum (25)(25 分)

Given a sequence of K integers { N~1~, N~2~, ..., N~K~ }. A continuous subsequence is defined to be { N~i~, N~i+1~, ..., N~j~ } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

代码:

#include <iostream>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;
const int max1 = 11000;
struct node
{
    int start;
    int end;
    int zsum;
    int s; int e;
};
vector< node> pp;
bool cmp(const node&a, const node&b)
{
    if (a.zsum != b.zsum)return a.zsum > b.zsum;
    else if(a.zsum==b.zsum) return a.s + a.e < b.s + b.e;
}
int main()
{
    int m;
    int s[max1];
    int sum = -9999; int total = 0; int g = 0;
    int flag = 0;
    cin >> m;
    for (int i = 0; i < m; i++)
    {
        cin >> s[i]; if (s[i]>=0)flag = 1;
    }
    for (int i = 0; i < m; i++)  {  //起点从0到m-1的串
        node ww; g = 0; ww.s = i; ww.start = s[i];
        for (int j = i; j < m; j++)               //终点从0到m-1的串便利
        {
            total += s[j]; g++;
            if (total >sum)
            {
                sum = total; ww.zsum = sum; ww.e = i + g - 1; ww.end = s[i + g - 1];
            }
        }
        pp.push_back(ww); sum = -9999; total = 0;
    }
    //for (; qk != pp.end();qk++)
    //cout << qk->zsum << " " << qk->start << " " << qk->end << endl;
    sort(pp.begin(), pp.end(), cmp); auto qk = pp.begin();
    if (flag==0)cout << "0" << " " << s[0] << " " << s[m - 1];
    else
        cout << qk->zsum << " " << qk->start << " " << qk->end;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/luoshiyong123/article/details/81320647