火星数字,运用map


火星数字


注:题目非原创
火星人是以13进制计数的:
地球人的0被火星人称为tret。
地球人数字1到12的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
火星人将进位以后的12个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。
例如地球人的数字“29”翻译成火星文就是“hel mar”;而火星文“elo nov”对应地球数字“115”。为了方便交流,请你编写程序实现地球和火星数字之间的互译。
输入格式:
输入第一行给出一个正整数N(<100),随后N行,每行给出一个[0, 169)区间内的数字 —— 或者是地球文,或者是火星文。
输出格式:
对应输入的每一行,在一行中输出翻译后的另一种语言的数字。
输入样例:
4
29
5
elo nov
tam
输出样例:
hel mar
may
115
13
代码如下:

#include <cstdio>
#include <cstring>
#include <stack>
#include <map>
#include <iostream>
#include <algorithm>
using namespace std;

int n;
char low[13][10] = {"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
char high[13][10] = {"tret", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
map<string, int> lownum;
map<string, int> highnum;
stack<string> ans1;

void tohuo(int n){
  if (n == 0) {cout << "tret" << endl; return;}
  bool key = true;
  while(n){
    if (key && n%13!=0) ans1.push(low[n%13]);
    if(!key) ans1.push(high[n%13]);
    n/=13;
    key = false;
  }
  while(!ans1.empty()){
    if (ans1.size()==1) cout << ans1.top() << endl;
    else cout << ans1.top() << ' ';
    ans1.pop();
  }
}

void tonum(char* arr){

  if(strlen(arr) <= 4){
    if(lownum.count(arr)) printf("%d\n", lownum[arr]);
    else printf("%d\n", highnum[arr]*13);
  }  
  else {
    arr[3] = '\0';
    printf("%d\n", highnum[arr]*13+lownum[arr+4]);
  }
}



int main()
{  
  cin >> n;
  getchar();
  for (int i = 0; i<13; i++){
    lownum.insert(make_pair(low[i], i));
    highnum.insert(make_pair(high[i], i));
  }
  for (int i = 0; i<n; i++){
    char a[20];
    gets(a);
    if(isdigit(a[0])) tohuo(atoi(a));
    else tonum(a);
  }

  return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_42866708/article/details/81367724
今日推荐