【HDU 1242】Rescue(基础bfs)

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 37157    Accepted Submission(s): 12913


 

Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

 

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.

 

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 

 

Sample Input

 

7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........

 

Sample Output

 

13

 

Author

CHEN, Xue

 

BFS入门题,直接走就好了。

#include<bits/stdc++.h>
using namespace std;
#define MAXN 260
char maze[MAXN][MAXN];
int n,m;
struct node
{
	int x,y;
	int step;
	friend bool operator<(node a,node b)
	{
		return a.step>b.step;
	}
};
int vis[MAXN][MAXN];
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
void BFS(int x1,int y1,int x2,int y2)
{
	memset(vis,0,sizeof(vis));
	priority_queue<node> que;
	node e1,e2;
	int ans=-1;
	e1.x=x1,e1.y=y1;
	e1.step=0;
	que.push(e1);
	vis[x1][y1]=1;
	while(!que.empty())
	{
		e1=que.top();
		que.pop();
		if(e1.x==x2&&e1.y==y2)
		{
			ans=e1.step;
			break;
		}
		for(int i=0;i<4;i++)
		{
			e2.x=e1.x+dir[i][0];
			e2.y=e1.y+dir[i][1];
			if(e2.x<0||e2.x>=n||e2.y<0||e2.y>=m||vis[e2.x][e2.y]||maze[e2.x][e2.y]=='#') continue;
			if(maze[e2.x][e2.y]=='.'||maze[e2.x][e2.y]=='r')
			{
				e2.step=e1.step+1;
			}
			else 
			{
				e2.step=e1.step+2;
			}
			que.push(e2);
			vis[e2.x][e2.y]=1;
		}
	}
	if(ans==-1) cout<<"Poor ANGEL has to stay in the prison all his life."<<endl;
	else cout<<ans<<endl;
}
int main()
{
	ios::sync_with_stdio(0);
	int sx,sy;
	int ex,ey;
	while(cin>>n>>m)
	{
		for(int i=0;i<n;i++) cin>>maze[i];
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<m;j++)
			{
				if(maze[i][j]=='a') sx=i,sy=j;
				else if(maze[i][j]=='r') ex=i,ey=j;
			}
		}
		BFS(sx,sy,ex,ey);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/duanghaha/article/details/81382043
今日推荐