Rescue(hdu 1242)

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36566    Accepted Submission(s): 12652


 

Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

 

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.

 

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 

 

Sample Input

7 8

#.#####.

#.a#..r.

#..#x...

..#..#.#

#...##..

.#......

........

Sample Output

13

Author

CHEN, Xue

Source

ZOJ Monthly, October 2003

 逆向BFS,优先队列,考察逆向思维

#include<bits/stdc++.h>
using namespace std;
char g[205][205];
int vis[205][205],ans,n,m,flag;
int dir[4][2]= {{0,1},{0,-1},{1,0},{-1,0}};
struct node
{
    int x,y;
    int step;
    friend bool operator<(const node& a,const node& b)
    {
        return a.step>b.step;
    }
};
priority_queue<node>q;
void bfs()
{
    while(!q.empty())
    {
        node t=q.top();
        q.pop();
        if(g[t.x][t.y]=='r')
        {
            flag=1;
            ans=t.step;
            break;
        }
        for(int i=0; i<4; i++)
        {
            int newx=t.x+dir[i][0];
            int newy=t.y+dir[i][1];
            if(g[newx][newy]=='#'||vis[newx][newy]||newx<0||newx>=n||newy<0||newy>=m) continue;
            vis[newx][newy]=1;
            node p;
            p.x=newx,p.y=newy;
            if(g[newx][newy]=='x') p.step=t.step+2;
            else p.step=t.step+1;
            q.push(p);
        }
    }
}
int main()
{
    int x,y;
    while(scanf("%d%d",&n,&m)==2)
    {
        for(int i=0; i<n; i++)
        {
            scanf("%s",g[i]);
            for(int j=0; j<m; j++)
            {
                if(g[i][j]=='a')
                {
                    x=i,y=j;
                }
            }
        }
        while(!q.empty()) q.pop();
        memset(vis,0,sizeof(vis));
        node t;
        flag=0;
        t.x=x,t.y=y,t.step=0;
        q.push(t);
        vis[x][y]=1;
        bfs();
        if(flag) printf("%d\n",ans);
        else printf("Poor ANGEL has to stay in the prison all his life.\n");
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41061455/article/details/81163965