HDU 1242 Rescue

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 37852    Accepted Submission(s): 13142

 

Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

 

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.

 

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 

 

Sample Input

7 8

#.#####.

#.a#..r.

#..#x...

..#..#.#

#...##..

.#......

........

 

Sample Output

13

Author

CHEN, Xue

 

Source

ZOJ Monthly, October 2003

 

Recommend

Eddy

代码:

#include<iostream>
#include<queue>
#include<string.h>
#include<cstring>
#include<cstdio>
using namespace std;
char flag[205][205];
int t, n, m, direction[4][2] = { {-1,0},{1,0},{0,-1},{0,1} };
struct position
{
	int x, y, step;
}start, eend;
int bfs()
{
	queue<position> Q;
	position current, next;
	flag[start.x][start.y] = '#';
	start.step = 0;
	Q.push(start);
	while (!Q.empty())
	{
		current = Q.front();
		Q.pop();
		if (current.x == eend.x&&current.y == eend.y)return current.step;
		for (int i = 0; i < 4; i++)
		{
			next.x = current.x + direction[i][0];
			next.y = current.y + direction[i][1];
			if ((next.x >= 0 && next.x < n) && (next.y >= 0 && next.y < n) && flag[next.x][next.y] != '#')
			{
				next.step = current.step + 1;
				if (flag[next.x][next.y] == 'x')
					next.step++;
				flag[next.x][next.y] = '#';
				Q.push(next);
			}
		}
	}
	return -1;
}
int main()
{
	while (~scanf("%d%d", &n, &m))
	{
		for (int i = 0; i < n; i++)
		{
			for (int j = 0; j < m; j++)
			{
				cin >> flag[i][j];
				if (flag[i][j] == 'r')
				{
					start.x = i;
					start.y = j;
				}
				if (flag[i][j] == 'a')
				{
					eend.x = i;
					eend.y = j;
				}
			}
		}
		t = bfs();
		if (t==-1)
		{
			cout << "Poor ANGEL has to stay in the prison all his life.\n";
		}
		else
			cout << t << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41020351/article/details/82631737