zcmu 2188

2188: Frames
时间限制: 2 Sec  内存限制: 256 MB
提交: 53  解决: 21
[提交][状态][讨论版]
题目描述
time limit per test
2 seconds
memory limit per test
256 megabytes
input
standard input
output
standard output
Throughout Igor K.'s life he has had many situations worthy of attention. We remember the story with the virus, the story of his mathematical career and of course, his famous programming achievements. However, one does not always adopt new hobbies, one can quit something as well.

This time Igor K. got disappointed in one of his hobbies: editing and voicing videos. Moreover, he got disappointed in it so much, that he decided to destroy his secret archive for good.

Igor K. use Pindows XR operation system which represents files and folders by small icons. At that, m icons can fit in a horizontal row in any window.

Igor K.'s computer contains n folders in the D: disk's root catalog. The folders are numbered from 1 to n in the order from the left to the right and from top to bottom (see the images). At that the folders with secret videos have numbers from a to b inclusive. Igor K. wants to delete them forever, at that making as few frame selections as possible, and then pressing Shift+Delete exactly once. What is the minimum number of times Igor K. will have to select the folder in order to select folders from a to b and only them? Let us note that if some selected folder is selected repeatedly, then it is deselected. Each selection possesses the shape of some rectangle with sides parallel to the screen's borders.

Input
The only line contains four integers n, m, a, b (1≤n,m≤109, 1≤a≤b≤n). They are the number of folders in Igor K.'s computer, the width of a window and the numbers of the first and the last folders that need to be deleted.

Output
Print a single number: the least possible number of times Igor K. will have to select the folders using frames to select only the folders with numbers from a to b.

Examples
Input
11 4 3 9
Output
3
Input
20 5 2 20
Output
2
Note
The images below illustrate statement tests.

The first test:

In this test we can select folders 3 and 4 with out first selection, folders 5, 6, 7, 8 with our second selection and folder 9 with our third, last selection.

The second test:

In this test we can first select all folders in the first row (2, 3, 4, 5), then − all other ones.

输入
输出
样例输入
样例输出
提示
来源

[提交][状态][讨论版]
中文  English  

心得:就是把情况列全就好了,结果就3个。

#include<bits/stdc++.h>
using namespace std;
int main(void)
{
	int n,m,a,b,st,ed;
	scanf("%d%d%d%d",&n,&m,&a,&b);
	if(a%m==0) st=a/m;
	else st=a/m+1;
	if(b%m==0) ed=b/m;
	else ed=b/m+1;
	if(m==1)
	{
		printf("1\n");
		return 0;
	}
	if(b==n)
	{
		if(a%m==1||st==ed) printf("1\n");
		else printf("2\n");
		return 0;
	}
	if(a%m==1&&b%m==0||st==ed)
	{
		printf("1\n");
		return 0;
	}
	if(a%m==1||b%m==0||st+1==ed||(b+1)%m==a%m)
	{
		printf("2\n");
	}
	else printf("3\n");
	return 0;
}

参考文章:http://www.bubuko.com/infodetail-704464.html

猜你喜欢

转载自blog.csdn.net/qq_41829060/article/details/81275024