zcmu 1092

1092: 输出一个整数的各位数字

Description

输入一个正整数 repeat (0<repeat<10),做repeat 次下列运算:
输入一个整数,从高位开始逐位输出它的各位数字。

Input

输入的整数可能大于1030

Output

见sample

Sample Input

3 123456 -600 8

Sample Output

1 2 3 4 5 6 6 0 0 8
 
思路:如果用数字来模拟除法,数字太大结果就不对。换一个思路,改用字符数组输入,如果遇到负号,从下标1开始打印,别的从下标0开始打印。
 
代码如下:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<map>
#include<time.h>
using namespace std;
#define FORA(i,x,y) for(int i = x; i < y; i++)
#define FORB(i,x,y) for(int i = x; i <= y; i++)
#define FORC(i,y,x) for(int i = y; i > x; i--)
#define maxn 100000
#define INF 1000000000
#define LL long long
const int mod = 1000000;
int a[maxn];
char b[maxn];
int main(){
    int t;
    scanf("%d",&t);
    getchar();
    while(t--){
        gets(b);
        if(b[0] == '-') {
            printf("%c",b[1]);
            FORA(i,2,strlen(b)){
                printf(" %c",b[i]);
            }
        }else {
            printf("%c",b[0]);
            FORA(i,1,strlen(b)) {
                printf(" %c",b[i]);
            }
        }
        printf("\n");
    }
    return 0;
}
 

猜你喜欢

转载自www.cnblogs.com/banyouxia/p/9445717.html