poj 3734 blocks (矩阵快速幂)

Description

Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.

Input

The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.

Output

For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.

Sample Input

2
1
2

Sample Output

2
6

题意:

有n块积木和4中颜色r,g,b,y要求积木中r,g的总个数都要为偶数,问符合条件的方案数。

代码:

#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;

struct mat{
        int a[3][3];
};

mat juzhen(mat x, mat y)
{
        int i,j;
        mat p;
        memset(p.a,0,sizeof(p.a));
        for(i=0;i<3;i++)
        {
                for(j=0;j<3;j++)
                {

                        for(int k=0;k<3;k++)
                {
                        p.a[i][j]=(p.a[i][j]+x.a[i][k]*y.a[k][j])%10007;

                }

                }
        }
        return p;
}

void mul(int n)
{
        int i;mat cnt;mat da;
        memset(cnt.a,0,sizeof(cnt.a));
        for(i=0;i<3;i++)
                cnt.a[i][i]=1;
    da.a[0][0]=2;da.a[0][1]=1;da.a[0][2]=0;
    da.a[1][0]=2;da.a[1][1]=2;da.a[1][2]=2;
    da.a[2][0]=0;da.a[2][1]=1;da.a[2][2]=2;
    //n=n-1;
    while(n>0)
    {
            if(n&1)
                cnt=juzhen(cnt,da);
            da=juzhen(da,da);
            n>>=1;
    }

    printf("%d\n",cnt.a[0][0]);
}

int main()
{
    int t;
    int n;
    scanf("%d",&t);
    while(t--)
    {
            scanf("%d",&n);
            mul(n);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/intelligentgirl/article/details/81329894