POJ2318——Toys(点和直线得位置关系+叉积)

题目:https://vjudge.net/contest/242905#problem/A

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint 

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

利用叉积,判断点和支线得位置关系

由于从前到后判断比较耗时,所以利用二分;

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <vector>
#include <math.h>
#define maxn 5005
using namespace std;
struct Point {
	double x, y;
	Point(double x=0, double y=0): x(x), y(y) {}					//构造函数
	Point operator + (Point p) {return Point(x+p.x, y+p.y);}				//两向量相加
	Point operator - (Point p) {return Point(x-p.x, y-p.y);}				//两向量相减
	Point operator * (double k) {return Point(k*x, k*y);}				//向量的数乘
	Point operator / (double k) {return Point(x/k, y/k);}				//向量的数乘(乘以一个分数)
	bool operator < (const Point &p) const {return x!=p.x ? (x<p.x):(y<p.y);}	//给点排序时使用(可以根据需要变化)
	double norm() {return x*x + y*y;}							//向量的范数
	double abs() {return sqrt(norm());}							//向量的大小
	double dot(Point p) {return x*p.x + y*p.y;}					//两向量内积
	double cross(Point p) {return x*p.y - y*p.x;}					//两向量外积
}P[maxn][2];

int ccw(Point p0, Point p1, Point p2) {
	Point v1 = p1-p0;
	Point v2 = p2-p0;
	if(v1.cross(v2) > 0) return 1;			//逆时针方向
	if(v1.cross(v2) < 0) return -1;			//顺时针方向
	if(v1.dot(v2) < 0) return 2;			//同一直线上的反方向
	if(v1.norm() < v2.norm()) return -2;	//同一直线上的正方向
	return 0;								//在向量上
}

int main()
{
    int n,m;
    double x1,x2,y1,y2;
    while(scanf("%d%d%lf%lf%lf%lf",&n,&m,&x1,&y1,&x2,&y2)==6&&n)
    {
        double U,L,xi,yi;
        for(int i=0;i<n;i++)
        {
            scanf("%lf%lf",&U,&L);
            P[i][0]=Point(U,y1);
            P[i][1]=Point(L,y2);
        }
        P[n][0]=Point(x2,y1);
        P[n][1]=Point(x2,y2);
        int ans[maxn];
        memset(ans,0,sizeof(ans));
        Point pp;
        while(m--)
        {
            scanf("%lf%lf",&xi,&yi);
            pp=Point(xi,yi);
            int left=0,right=n,mid,tmp;
            while(left<=right)
            {
                mid=(left+right)/2;
                if(ccw(P[mid][0],P[mid][1],pp)==1)
                {
                    left=mid+1;
                }
                else if(ccw(P[mid][0],P[mid][1],pp)==-1)
                {
                    tmp=mid;
                    right=mid-1;
                }
            }
            ans[tmp]++;
        }
        for(int i=0;i<=n;i++)
             printf("%d: %d\n",i,ans[i]);
             printf("\n");
    }
    return 0;
}
/*
4 4 1 5 10 2
2 3
5 4
6 7
9 8

2 2
3 3
4 4
5 3
*/

猜你喜欢

转载自blog.csdn.net/guagua_de_xiaohai/article/details/81332832