hdu1010 Tempter of the Bone 深搜dfs(论代码规范的重要性)

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 146539    Accepted Submission(s): 39069


 

Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

 

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

 

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

 

Sample Input

 

4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0

 

Sample Output

 

NO YES

 

Author

ZHANG, Zheng

 

Source

ZJCPC2004

思路:这道题直接暴力dfs肯定是TLE的,于是剪枝加回溯,剪枝可以了解一下奇偶剪枝,

现在说正点,本来这道题看着板子应该几下就搞定的,然而。。。。。。由于代码的不规范,debug调了一个多小时(也水了10多发tle),hdu也是有点骚,刚开始输出的大小写都不对都是TLE,果然是玄学啊,最后还是要感谢学长这么多事情还得抽空帮我找bug,十分感谢

不规范的地方我会在代码中注释,希望广大同胞们不要犯类似错误,以我为戒

代码:

#include<bits/stdc++.h>
using namespace std;
int n,m,T,ex,ey;
char maze[10][10];
bool vis[10][10];
bool flag = 0;
int dx[4][2] = {1,0,-1,0,0,1,0,-1};
void dfs(int x,int y,int t)
{
    vis[x][y] = 1;
    if (maze[x][y] == 'D' && t == T)
    {
        flag = 1;
        return ;
    }
    int pnetime = T - t - (abs(ex - x) + abs(ey - y));
    if (pnetime < 0 || pnetime & 1) return ;
    for (int i = 0;i < 4;i ++)
    {
        int fx = x + dx[i][0],fy = y + dx[i][1];
        if (fx >= 0 && fx < n && fy >= 0 && fy < m && !vis[fx][fy] && maze[fx][fy] != 'X')
        {
            dfs(fx,fy,t + 1);
            if (flag) return;
            vis[fx][fy] = 0;
        }
    }
}
int main()
{
    while (~scanf("%d %d %d",&n,&m,&T) &&(n || m || T))
    {
        memset(vis,0,sizeof(vis));
        memset(maze,0,sizeof(maze));
        for (int i = 0;i < n;i ++)
            scanf("%s",maze[i]);
        int bx,by;
        flag = 0;
        for (int i = 0;i < n;i ++)
            for (int j = 0;j < m;j ++)
                
                if (maze[i][j] == 'D')//这里刚开始我把起点判断出来后就开始dfs 
                    ex = i,ey = j;      //很明显这是不对的,因为终点还不一定已经找出来呢,论代码规范的重要性 
                else if (maze[i][j] == 'S')
                    bx = i,by = j;
        dfs(bx,by,0);
        if (flag) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/cloudy_happy/article/details/81334850