数据结构实验之链表三:链表的逆置

Problem Description

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。

Input

输入多个整数,以-1作为结束标志。

Output

输出逆置后的单链表数据。

Sample Input

12 56 4 6 55 15 33 62 -1

Sample Output

62 33 15 55 6 4 56 12

Hint

不得使用数组。

#include <stdio.h>
#include <stdlib.h>

struct node
{
    int data;
    struct node *next;
};
void display(struct node *head)
{
    struct node *p;
    p=head->next;
    while(p!=NULL)
    {
        if(p->next==NULL) printf("%d\n",p->data);
        else printf("%d ",p->data);
        p=p->next;
    }
}
int main()
{
    struct node *head,*p;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    p=(struct node *)malloc(sizeof(struct node));
    p->next=head->next;
    while(scanf("%d",&p->data)!=EOF&&p->data!=-1)
    {
        p->next=head->next;
        head->next=p;
        p=(struct node *)malloc(sizeof(struct node));
    }
    display(head);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/waitingac/article/details/81331614