数据结构实验之链表二:逆序建立链表

Problem Description

输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。

Input

第一行输入整数N;;
第二行依次输入N个整数,逆序建立单链表。

Output

依次输出单链表所存放的数据。

Sample Input

10
11 3 5 27 9 12 43 16 84 22 

Sample Output

22 84 16 43 12 9 27 5 3 11 

Hint

不能使用数组!

#include <stdio.h>
#include <stdlib.h>

struct node
{
    int data;
    struct node *next;
};
struct node *creat(int n)
{
    struct node *head,*p;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    int i;
    for(i=1;i<=n;i++)
    {
        p=(struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=head->next;
        head->next=p;
    }
    return (head);
}
void display(struct node *head)
{
    struct node *p;
    p=head->next;
    while(p!=NULL)
    {
        if(p->next==NULL) printf("%d\n",p->data);
        else printf("%d ",p->data);
        p=p->next;
    }
}
int main()
{
    int n;
    struct node *head;
    scanf("%d",&n);
    head=creat(n);
    display(head);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/waitingac/article/details/81330814
今日推荐