数据结构实验之链表五:单链表的拆分

数据结构实验之链表五:单链表的拆分

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。

Input

第一行输入整数N;;
第二行依次输入N个整数。

Output

第一行分别输出偶数链表与奇数链表的元素个数; 
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。

Sample Input

10
1 3 22 8 15 999 9 44 6 1001

Sample Output

4 6
22 8 44 6 
1 3 15 999 9 1001
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
struct node
{
    int data;
    struct node *next;
};

struct node *Createlist(int n)
{
    struct node *head,*p,*tail;
    int i;
    head = (struct node*)malloc(sizeof(struct node));
    tail = head;
    for(i=1;i<=n;i++)
    {
        p = (struct node*)malloc(sizeof(struct node));
        p->next = NULL;
        scanf("%d",&p->data);
        tail->next = p;
        tail = p;
    }
    return head;
};

void Dlist(struct node *head1,struct node *head2,struct node *head)
{
     struct node* tail1,*tail2,*p;
    int n,m;
    n=0;
    m=0;
    tail1=head1;
    tail2=head2;
    while(head){
        if(head->data%2==0){/*是偶数,建立一个单链表*/
            n++;
            p=(struct node*)malloc(sizeof(struct node));
            p->data=head->data;
            p->next=NULL;
            tail1->next=p;
            tail1=p;
        }
        else{
            m++;
            p=(struct node*)malloc(sizeof(struct node));
            p->data=head->data;
            p->next=NULL;
            tail2->next=p;
            tail2=p;
        }
        head=head->next;
    }
    printf("%d %d\n",n,m);
    for(p=head1->next;p!=NULL;p=p->next){
        if(p==head1->next)
            printf("%d",p->data);
        else
            printf(" %d",p->data);
    }
    printf("\n");
    for(p=head2->next;p!=NULL;p=p->next){
        if (p==head2->next)
            printf("%d",p->data);
        else
            printf(" %d",p->data);
    }

}

int main()
{
    struct node *head1,*head2,*head3,*q1;

    head1=(struct node*)malloc(sizeof(struct node));
    head1->next=NULL;
    head2=(struct node*)malloc(sizeof(struct node));
    head2->next = NULL;
    int m;
    scanf("%d",&m);
    head3=Createlist(m);
    q1=head3->next;
    Dlist(head1,head2,q1);

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_19168521/article/details/81488878