杭电-1702 ACboy needs your help again!(栈&队列)

ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5670    Accepted Submission(s): 2963

Problem Description

ACboy was kidnapped!! 
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input

The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.

扫描二维码关注公众号,回复: 2499009 查看本文章

Output

For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.

Sample Input

 

4 4 FIFO IN 1 IN 2 OUT OUT 4 FILO IN 1 IN 2 OUT OUT 5 FIFO IN 1 IN 2 OUT OUT OUT 5 FILO IN 1 IN 2 OUT IN 3 OUT

Sample Output

 

1 2 2 1 1 2 None 2 3

#include<cstdio>
#include<iostream>
#include<queue>
#include<stack>
#include<cstring>
using namespace std;
int main()
{
	int t;
	cin>>t;
	queue<int> q;
	stack<int> S;
	char ss[100];int n,m;
	while(t--){
		cin>>n>>ss;
		while(!q.empty()) q.pop();   //需要重新释放空间
		while(!S.empty()) S.pop();
		if(!strcmp(ss,"FIFO")){
			char cc[100];
			for(int i=0;i<n;i++){
				cin>>cc;
			if(!strcmp(cc,"IN")){
				cin>>m;q.push(m);
			}
			else if(!strcmp(cc,"OUT")){
				if(q.empty()) printf("None\n");
				else {
					printf("%d\n",q.front());
					q.pop();
				}
			}
		    }
		}
		else if(!strcmp(ss,"FILO")){
			char cc[100];
			for(int i=0;i<n;i++){
				cin>>cc;
				if(!strcmp(cc,"IN")){
                 cin>>m;S.push(m);
                }
            else if(!strcmp(cc,"OUT")){
                if(S.empty())
                    printf("None\n");
                else{
                    printf("%d\n",S.top());
                    S.pop();
                }
            }
            }
		}
		else
		   printf("error\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/gao506440410/article/details/81234537