ACboy needs your help again!

ACboy was kidnapped!! 
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(. 
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy." 
The problems of the monster is shown on the wall: 
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out"). 
and the following N lines, each line is "IN M" or "OUT", (M represent a integer). 
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
InputThe input contains multiple test cases. 
The first line has one integer,represent the number oftest cases. 
And the input of each subproblem are described above.OutputFor each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.Sample Input
4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT
Sample Output
1
2
2
1
1
2
None
2
3
#include<cstdio>
#include<cstring>
#include<stack>
#include<queue>
#include<algorithm>
using namespace std;
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		int a;
		char b[10];
		scanf("%d%s",&a,&b);
		if(strcmp(b,"FIFO")==0){
			queue<int> q;
			while(a--){
				int c;
				char d[10];
				scanf("%s",&d);
				if(strcmp(d,"IN")==0){
					scanf("%d",&c);
					q.push(c);
				}
				else if(q.empty()){
					printf("None\n");
				}
				else {
					printf("%d\n",q.front());
					q.pop();
				}
			}
		}
		else if(strcmp(b,"FILO")==0) {
			stack<int> s;
			while(a--){
				int c;
				char d[10];
				scanf("%s",&d);
				if(strcmp(d,"IN")==0){
					scanf("%d",&c);
					s.push(c);
				}
				else if(s.empty()){
					printf("None\n");
				}
				else {
					printf("%d\n",s.top());
					s.pop();
				}
			}
		}
	}
	return 0;
} //标准栈和队列的用法,掌握基础后理解并不困难。

猜你喜欢

转载自blog.csdn.net/miku531/article/details/79660804
今日推荐