I - ACboy needs your help

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.

Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain.

Sample Input

2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0

Sample Output

3
4
6

题意:有n个课程,现在花M天来学习这些课程,学习每个课程花的天数所得到的价值不同,求M天怎么分配学习才能得到的价值最大。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
using namespace std;
int dp[105],mp[105][105]; 
int main(){
	int n,m;
	while(scanf("%d%d",&n,&m)&&(n+m)){
		memset(dp,0,sizeof dp);
		for(int i=1;i<=n;i++){
			for(int j=1;j<=m;j++){
				scanf("%d",&mp[i][j]);
			} 
		}
		for(int i=1;i<=n;i++){//组别
			for(int j=m;j>=1;j--){//容量体积
				for(int k=1;k<=j;k++)//对于j天监考有k天选择组别i
					dp[j]=max(dp[j],dp[j-k]+mp[i][k]);
			}
		}
		printf("%d\n",dp[m]);
	}	
	return 0;
} 

tip:对于每组容量更新,一定要从后往前,因为更新要受到小于它的天数的dp的影响,而这个影响不能由小于它的本组天数产生!

猜你喜欢

转载自blog.csdn.net/qq_39825375/article/details/84727653