HDU---1702 ACboy needs your help again!

ACboy needs your help again!

ACboy was kidnapped!!

he miss his mother very much and is very scare now.You can’t image how dark the room he was put into is, so poor ?.

As a smart ACMer, you want to get ACboy out of the monster’s labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can’t solve my problems, you will die with ACboy."

The problems of the monster is shown on the wall:

Each problem’s first line is a integer N(the number of commands), and a word “FIFO” or “FILO”.(you are very happy because you know “FIFO” stands for “First In First Out”, and “FILO” means “First In Last Out”).

and the following N lines, each line is “IN M” or “OUT”, (M represent a integer).

and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!**
Input
The input contains multiple test cases.

The first line has one integer,represent the number oftest cases.

And the input of each subproblem are described above.

Output
For each command “OUT”, you should output a integer depend on the word is “FIFO” or “FILO”, or a word “None” if you don’t have any integer.

Sample Input
4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

Sample Output

1
2
2
1
1
2
None
2
3

本题题意:

本题包含了FIFO和FILO,表示先进先出和先进后出,IN表示加入数据,OUT表示弹出数据,如果没有数据则输出None。

思路:

由先进先出可以想到队列就是先进先出的,先进后出可以想到栈就是先进后出的,由此我们可以用到STL容器,遇到FIFO直接入队,遇到FILO直接入栈。

AC代码如下:


#include<stack>
#include<queue>
#include<string>
#include<iostream>
using namespace std;
int main()
{	

	int t;
	cin >> t;
	while (t--)
	{
		stack<int>a1;
		queue<int>q1;
		int n;
		string a,b,c;//fi,in,out
	    	cin >> n >> a;

			if (a == "FIFO")
			{
			while (n--)
			{
				cin >> b;
				if (b == "IN")
				{
					int m;
					cin >> m;
					q1.push(m);
				}
				else if (b == "OUT")
				{
					if (q1.empty())
					{
					cout << "None" << endl;
						continue;
					}
					else{
						cout << q1.front() << endl;
						q1.pop();
					}
					
				}
			}
		}
		else if(a=="FILO"){
			
			while (n--)
			{
				cin >> b;
				if (b == "IN")
				{
					int m;
					cin >> m;
					a1.push(m);

				}
				else if(b=="OUT"){

					if (a1.empty())
					{
						cout << "None" << endl;
						continue;

					}

					else{
						cout << a1.top() << endl;
						a1.pop();
					}
					
				}

			}
			
		}
}


return 0;
}
发布了40 篇原创文章 · 获赞 10 · 访问量 2572

猜你喜欢

转载自blog.csdn.net/lsdstone/article/details/101111391
今日推荐