数据结构实验之二叉树七:叶子问题

数据结构实验之二叉树七:叶子问题

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立该二叉树并按从上到下从左到右的顺序输出该二叉树的所有叶子结点。

Input

  输入数据有多行,每一行是一个长度小于 50 个字符的字符串。

Output

  按从上到下从左到右的顺序输出二叉树的叶子结点。

Sample Input

abd,,eg,,,cf,,,
xnl,,i,,u,,

Sample Output

dfg
uli


#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct node
{
    char num;
    struct node *l,*r;
};

int z,flog;
char i[1000];

struct node *kk()
{
    struct node *root;
    if(i[++flog]==',')
    return NULL;
    else
    {
        root=(struct node *)malloc(sizeof(struct node));
        root->num=i[flog];
        root->l=kk();
        root->r=kk();
    }
    return root;
};

void gg(struct node *root)
{
    if(root==NULL)
        return ;
    int f=1,i=1;
    struct node *s[1000],*p;
    s[1]=root;
    while(f<=i)
    {
        p=s[f++];
        if(p->l!=NULL)
        {
            s[++i]=p->l;
        }
        if(p->r!=NULL)
        {
            s[++i]=p->r;
        }
        if(p->l==NULL&&p->r==NULL)
        {
            printf("%c",p->num);
        }
    }
}
int main()
{
    struct node *root;
    while(gets(i))
    {
        flog=-1;
        root=kk();
        gg(root);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/the_city_of_the__sky/article/details/80542504