数据结构实验之二叉树三:统计叶子数

数据结构实验之二叉树三:统计叶子数

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并求二叉树的叶子结点个数。

Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output

输出二叉树的叶子结点个数。

Sample Input

abc,,de,g,,f,,,

Sample Output

3


#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct node
{
    char num;
    struct node *l,*r;
};
int z,flog;
char i[1000];
struct node *kk()
{
    struct node *root;
    if(i[++flog]==',')
        return NULL;
    else
    {
        root=(struct node *)malloc(sizeof(struct node));
        root->num=i[flog];
        root->l=kk();
        root->r=kk();
        if(root->l==NULL&&root->r==NULL)
        z++;
    }
    return root;
};

int main()
{
    while(gets(i))
    {
        flog=-1;
        z=0;
        kk();
        printf("%d\n",z);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/the_city_of_the__sky/article/details/80542484