Cow Contest POJ - 3660(floyed求传递闭包)

N (1 ≤ N ≤ 100) cows, conveniently numbered 1…N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2…M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

  • Line 1: A single integer representing the number of cows whose ranks can be determined

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2
思路:很少写floyed,但是这个算法解决这种所有顶点之间的关系很容易理解。在数据量不大的情况下是可以接受的。
该题思路:
①对于a胜于b,我们使得mp[a][b]=1.
②floyed更新各个点之间的关系。
③遍历每两对点,如果mp[i][j]==1或者mp[j][i]==1的话(i>j或者j>i的个数),计数加一。最后如果计数总数为n-1的话,就代表它和其他n-1个点的关系都确定,那么它的排名就确定。
代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int maxx=1e2+10;
int mp[maxx][maxx];
int n,m;

inline void floyed()
{
	for(int k=1;k<=n;k++)//循环顺序!!!
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				if(mp[i][k]&&mp[k][j]) mp[i][j]=1;
			}
		}
	}
}
inline void solve()
{
	int sum=0,ans=0;
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=n;j++)
		{
			if(mp[i][j]||mp[j][i]) sum++;
		}
		if(sum==n-1) ans++;
		sum=0;
	}
	cout<<ans<<endl;
}
int main()
{
	memset(mp,0,sizeof(mp));
	scanf("%d%d",&n,&m);
	int x,y;
	while(m--)
	{
		scanf("%d%d",&x,&y);
		mp[x][y]=1;
	}
	floyed();
	solve();
	return 0;
}

努力加油a啊,(o)/~

发布了596 篇原创文章 · 获赞 47 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/starlet_kiss/article/details/105078796
今日推荐