poj 2084 Game of Connections 卡特兰数+大数

Game of Connections

Time Limit: 1000MS

 

Memory Limit: 30000K

Total Submissions: 8303

 

Accepted: 4133

Description

This is a small but ancient game. You are supposed to write down the numbers 1, 2, 3, . . . , 2n - 1, 2n consecutively in clockwise order on the ground to form a circle, and then, to draw some straight line segments to connect them into number pairs. Every number must be connected to exactly one another. 
And, no two segments are allowed to intersect. 
It's still a simple game, isn't it? But after you've written down the 2n numbers, can you tell me in how many different ways can you connect the numbers into pairs? Life is harder, right?

Input

Each line of the input file will be a single positive number n, except the last line, which is a number -1. 
You may assume that 1 <= n <= 100.

Output

For each n, print in a single line the number of ways to connect the 2n numbers into pairs.

Sample Input

2

3

-1

Sample Output

2

5


算法分析:

 

题意:2n个人围成一圈,两两互相连接,且连接的线不能交叉,问有多少种方式。

分析:根据数据可以推出是Catalan数,根据Calalan的递推式:h(n) = h(n-1)*(4n-2)/(n+1)可以计算,又因为数据比较大,所以需要模拟大数的乘法和除法。

更多求卡特兰数的模板(点这里

代码实现:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
#define MAX 100
#define BASE 10000
void multiply(int a[],int Max,int b)
{//大数乘法 
	int i,array=0;
	for(i=Max-1;i>=0;i--)
	{
		array += b*a[i];
		a[i] = array%BASE;
		array /= BASE;		
	}
}
 
void divide(int a[],int Max,int b)
{//大数除法 
	int i,div=0;
	for(i=0;i<Max;i++)
	{
		div =div * BASE + a[i];
		a[i] = div/b;
		div%=b;	
	}
}
 
 
int main()
{
	int i,j,n;
	int a[105][MAX];
	memset(a[1],0,sizeof(a[1]));
	for(i=2,a[1][MAX-1]=1;i<=100;i++)
	{
		memcpy(a[i],a[i-1],sizeof(a[i-1]));
		multiply(a[i],MAX,4*i-2);
		divide(a[i],MAX,i+1);
	}
	while(cin>>n,n!=-1)
	{
		for(i=0;i<MAX && a[n][i]==0;i++);
		cout<<a[n][i++];
		for(;i<MAX;i++)
			printf("%04d",a[n][i]);
		cout<<endl;
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/sdz20172133/article/details/81671805
今日推荐