CCF.2013 12-1 出现次数最多的数(map容器)

问题描述

试题编号: 201312-1
试题名称: 出现次数最多的数
时间限制: 1.0s
内存限制: 256.0MB
问题描述:

问题描述

  给定n个正整数,找出它们中出现次数最多的数。如果这样的数有多个,请输出其中最小的一个。

输入格式

  输入的第一行只有一个正整数n(1 ≤ n ≤ 1000),表示数字的个数。
  输入的第二行有n个整数s1, s2, …, sn (1 ≤ si ≤ 10000, 1 ≤ i ≤ n)。相邻的数用空格分隔。

输出格式

  输出这n个次数中出现次数最多的数。如果这样的数有多个,输出其中最小的一个。

样例输入

6
10 1 10 20 30 20

样例输出

10

解题思路:map 容器的简单应用。

#include<iostream>
#include<cstring>
#include<map>
using namespace std;

int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);

    int n;
    map<int,int>a;
    while(cin>>n)
    {
        int m,ans=0,maxn=-1;
        for(int i=0; i<n; i++)
        {
            cin>>m;
            a[m]++;
        }
        for(map<int,int>::iterator it=a.begin(); it!=a.end(); it++)
        {
            if(it->second>maxn)
            {
                maxn=it->second;
                ans=it->first;
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xxxxxm1/article/details/81271921
今日推荐