CCF-201312-1-出现次数最多的数



问题描述
  给定n个正整数,找出它们中出现次数最多的数。如果这样的数有多个,请输出其中最小的一个。
输入格式
  输入的第一行只有一个正整数n(1 ≤ n ≤ 1000),表示数字的个数。
  输入的第二行有n个整数s1, s2, …, sn (1 ≤ si ≤ 10000, 1 ≤ i ≤ n)。相邻的数用空格分隔。
输出格式
  输出这n个次数中出现次数最多的数。如果这样的数有多个,输出其中最小的一个。
样例输入
6
10 1 10 20 30 20

样例输出
10

问题描述
  给定n个正整数,找出它们中出现次数最多的数。如果这样的数有多个,请输出其中最小的一个。
输入格式
  输入的第一行只有一个正整数n(1 ≤ n ≤ 1000),表示数字的个数。
  输入的第二行有n个整数s 1, s 2, …, s n (1 ≤ s i ≤ 10000, 1 ≤ i ≤ n)。相邻的数用空格分隔。
输出格式
  输出这n个次数中出现次数最多的数。如果这样的数有多个,输出其中最小的一个。
样例输入
6
10 1 10 20 30 20
样例输出
10

C++代码实现如下:

#include<iostream>
#include<map>
using namespace std;
int main(){
	int n;
	cin>>n;
	map<int,int> m;
	for(int i = 0;i < n;i++){
		int x;
		cin>>x;
		m[x]++;
	}
	
	int ans,count = 0;
	for(map<int,int>::iterator it = m.begin();it != m.end();it++){
		if(it->second > count){
			count = it->second;
			ans = it->first;
		}
	}
	
	cout<<ans<<endl;
	return 0;
} 


猜你喜欢

转载自blog.csdn.net/Constantdropping/article/details/79533524
今日推荐