CCF201312-1 出现次数最多的数(100分)

试题编号: 201312-1
试题名称: 出现次数最多的数
时间限制: 1.0s
内存限制: 256.0MB
问题描述:

问题描述

  给定n个正整数,找出它们中出现次数最多的数。如果这样的数有多个,请输出其中最小的一个。

输入格式

  输入的第一行只有一个正整数n(1 ≤ n ≤ 1000),表示数字的个数。
  输入的第二行有n个整数s1, s2, …, sn (1 ≤ si ≤ 10000, 1 ≤ i ≤ n)。相邻的数用空格分隔。

输出格式

  输出这n个次数中出现次数最多的数。如果这样的数有多个,输出其中最小的一个。

样例输入

6
10 1 10 20 30 20

样例输出

10

问题分析:首先输入正整数n,接着输入n个正整数,求出其中出现次数最多的,如果出现次数相同则求出最小的那个。使用STL的map进行统计。

/*201312-1 出现次数最多的数 */
#include <iostream>
#include <map>
using namespace std;

int main ()
{
	int n, v;
	map<int, int> m;

	cin >> n;
	for(int i=1; i<=n; i++){
		cin >> v;
		m[v]++;
	}
	
	int ans,cnt=0;
	map<int,int>::iterator it;
	for(it=m.begin(); it!=m.end(); it++)
		if(it->second > cnt){
			cnt = it->second;
			ans = it->first;
		}

	cout<<ans<<endl;
	return 0;	
}

猜你喜欢

转载自blog.csdn.net/Highlight_Jin/article/details/81639268
今日推荐