YTU OJ 3288: 整除的尾数

版权声明:欢迎大佬批评指正!O(∩_∩)O https://blog.csdn.net/wyh1618/article/details/82595959

3288: 整除的尾数

题目描述

一个整数,只知道前几位,不知道末二位,被另一个整数除尽了,那么该数的末二位该是什么呢? 

输入

输入数据有若干组,每组数据包含二个整数a,b(0<a<10000, 10<b<100),若遇到0 0则处理结束。 

输出

对应每组数据,将满足条件的所有尾数在一行内输出,格式见样本输出。同组数据的输出,其每个尾数之间空一格,行末没有空格。 

样例输入

200 40
1992 95
0 0

样例输出

00 40 80
15
#include<stdio.h>
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    int n,m,i,j,k;
    int a[999];
    while(scanf("%d %d",&n,&m)&&(n||m))
    {
    for(i=0;i<100;i++)
    {
        if((n*100+i)%m==0)
        {
            if(i<10)
            {
                printf("0%d ",i);
            }
            else
                printf("%d ",i);
        }
    }
    printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wyh1618/article/details/82595959