YTU OJ 2377: Doorman

版权声明:欢迎大佬批评指正!O(∩_∩)O https://blog.csdn.net/wyh1618/article/details/83274444

Doorman

题目描述

The doorman Bruno at the popular night club Heaven is having a hard time fulfilling his duties. He was told by the owner that when the club is full, the number of women and men let into the club should be roughly the same. When the night club opens, people wanting to enter the club are already lined up in a queue, and Bruno can only let them in one-by-one. He lets them in more-or-less in the order they are lined up. He can however decide to let the second person in the queue cut the line and slip into the club before the person in front. This will no doubt upset the person first in line, especially when this happens multiple times,but Bruno is quite a big guy and is capable of handling troublemakers. Unfortunately though, he is not that strong on mental calculations under these circumstances.He finds keeping track of the difference of the number of women and number of men let into the club a challenging task. As soon as the absolute difference gets too big, he looses track of his counting and must declare to the party people remaining in the queue that the club is full.

输入

The first line of input contains a positive integer X< 100 describing the largest absolute difference between the number of women and number of men let into the club, that Bruno can handle. The second line contains a string consisting solely of the characters ’W’ and ’M’ of length at most 100, describing the genders of the people in the queue, in order. The leftmost character of the string is the gender of the person first in line.

输出

The maximum number of people Bruno can let into the club without loosing track of his counting. You may assume that the club is large enough to hold all the people in the queue.

样例输入

2
WMMMMWWMMMWWMW

样例输出

8
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
    int n,m,w,i,j,k,l;
    int a[1001]={0};
    int b[1001]={0};
    char str[1001];
    cin>>n;
    cin>>str;
    int len=strlen(str);
    bool flag=true;
    int sum=0;
    m=0;
    w=0;
    for(i=0;i<len;i++)
    {
        if(str[i]=='W')
        {
            if(w-m<n)
            {
                w++;
            }
            else
            {
                if(w-m==n)
                {
                    if(str[i+1]=='M')
                    {
                        m++;
                        w++;
                        i++;
                    }
                    else
                    {
                        break;
                    }
                }
            }
        }
        else
        {
            if(m-w<n)
            {
                m++;
            }
            else
            {
                if(m-w==n)
                {
                    if(str[i+1]=='W')
                    {
                        m++;
                        w++;
                        i++;
                    }
                    else
                    {
                        break;
                    }
                }
            }
        }
    }
    cout<<w+m<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wyh1618/article/details/83274444