B - Candy Sharing Game

A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy. 
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with. 
InputThe input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself. 
OutputFor each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line. 
Sample Input
6
36
2
2
2
2
2
11
22
20
18
16
14
12
10
8
6
4
2
4
2
4
6
8
0
Sample Output
15 14
17 22
4 8


        
  
Hint
The game ends in a finite number of steps because:
1. The maximum candy count can never increase.
2. The minimum candy count can never decrease.
3. No one with more than the minimum amount will ever decrease to the minimum.
4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.

    直接重新定义一个和N一样长的数组,然后把每个人糖果的一半数量存进去,原数组的值都减半,再加上新定义的数组的值,也就是说原本数组的第i+1个值减半再加上新定义的数组的第i个值,就是一轮获得的糖,然后再考虑是奇数个老师给一个糖。递归。


#include <stdio.h>
#include <stdlib.h>

#define MAXNUM 100

int moni(int gametime, int num, int stu[]);
int isfinal(int stu[], int num);

int finalnum;

int main()
{
    int N;
    int stu[MAXNUM];
    int gametime;
    int i;
    while(1)
    {
        scanf("%d", &N);
        if(N==0)    break;
        for(i=0; i<N; i++)
        {
            scanf("%d", &stu[i]);
        }
        finalnum=0;
        gametime=moni(0, N, stu);
        printf("%d %d\n", gametime, finalnum);
    }
    return 0;
}

int moni(int gametime, int num, int stu[])
{
    if(isfinal(stu, num))    return gametime;
    gametime++;
    int temp[num];
    int i;
    for(i=0; i<num; i++)
    {
        stu[i]=stu[i]/2;
        temp[i]=stu[i];
    }
    stu[0]=stu[0]+temp[num-1];
    stu[0]=stu[0]+stu[0]%2;
    for(i=1; i<num; i++)
    {
        stu[i]=stu[i]+temp[i-1];
        stu[i]=stu[i]+stu[i]%2;
    }
    return moni(gametime, num, stu);
}

int isfinal(int stu[], int num)
{
    int i;
    for(i=1; i<num; i++)
    {
        if(stu[0]!=stu[i])
            return 0;
    }
    finalnum=stu[0];
    return 1;
}

猜你喜欢

转载自blog.csdn.net/qq_40560275/article/details/80849582