最短路——Dijkstra变形 POJ1797

Heavy Transportation

 

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5
Sample Output
Scenario #1:
4


简而言之就是把原来的求最短路成改成了找出一条路线,满足全部路程中的最小值最大(即找出载重量最大的一种行走方案)

代码:

#include<iostream>
#include<queue>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#define inf 50000000
using namespace std;
int a[1005][1005];
int i,j,k,v,u,n,m,N,x,y,s,mint,book[1005],vis[1005],q[1005];
void Dijkstra() {
	for(j=1;j<=n;j++) vis[j]=a[1][j];
	for(j=1;j<=n;j++) {
		mint=0;
		for(k=1;k<=n;k++) {
			if(book[k]==0&&vis[k]>mint) {    //找出和起点相邻的路的最大载重量
				mint=vis[k];
				u=k;
			}
		}
		book[u]=1;
		for(k=1;k<=n;k++) {	
			if(book[k]==0&&vis[k]<vis[u]&&vis[k]<a[u][k]) {    //当有更大载重量的两段路时,松弛
				vis[k]=min(vis[u],a[u][k]);
			}
		}
	}
}
int main() {
	cin>>N;
	for(i=1;i<=N;i++) {
		cin>>n>>m;
		memset(book,0,sizeof(book));
		for(j=1;j<=n;j++) for(k=1;k<=n;k++) a[j][k]=0;    //初始化所有路的载重量都是0
		for(j=1;j<=m;j++) {
			cin>>x>>y>>s;
			if(a[x][y]<s) a[x][y]=a[y][x]=s;    //载重量更大时赋值
		}
		Dijkstra();
		printf("Scenario #%d:\n",i);
		printf("%d\n\n",vis[n]);
	}
}

猜你喜欢

转载自blog.csdn.net/littlewhitelv/article/details/80024650