三角形,hduoj 虽为水题,但也很经典

三角形

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 109965    Accepted Submission(s): 36025


 

Problem Description

给定三条边,请你判断一下能不能组成一个三角形。

 

 

Input

输入数据第一行包含一个数M,接下有M行,每行一个实例,包含三个正数A,B,C。其中A,B,C <1000;                                                  没说int型,认真看题,考察细心度。

 

 

Output

对于每个测试实例,如果三条边长A,B,C能组成三角形的话,输出YES,否则NO

 

 

Sample Input

2

1 2 3

2 2 2

 

 

Sample Output

NO

YES

 

 

Author

linle

 

 

Source

2005实验班短学期考试

 

#include<stdio.h>

#include<math.h>

int main()

{

    int n;

    int i,j;

    scanf("%d",&n);

   

           double a,b,c;

           while(n--)

           {

                  scanf("%lf %lf %lf",&a,&b,&c);

                  if(a+b>c&&a+c>b&&b+c>a&&abs(a-b)<=c&&abs(a-c)<=b&&abs(b-c)<=a)

                  printf("YES\n");

                  else

                  printf("NO\n");

              }

  

       return 0;

}

猜你喜欢

转载自blog.csdn.net/qq_41325698/article/details/81176365