Buildings Gym - 101873B

版权声明:本文为博主瞎写的,请随便转载 https://blog.csdn.net/sdut_jk17_zhangming/article/details/82025110

As a traveling salesman in a globalized world, Alan has always moved a lot. He almost never lived in the same town for more than a few years until his heart yearned for a different place. However, this newest town is his favorite yet - it is just so colorful. Alan has recently moved to Colorville, a smallish city in between some really nice mountains. Here, Alan has finally decided to settle down and build himself a home - a nice big house to call his own. In Colorville, many people have their own houses - each painted with a distinct pattern of colors such that no two houses look the same. Every wall consists of exactly n × n squares, each painted with a given color (windows and doors are also seen as unique “colors”). The walls of the houses are arranged in the shape of a regular m-gon, with a roof on top. According to the deep traditions of Colorville, the roofs should show the unity among Colorvillians, so all roofs in Colorville have the same color. Figure B.1: Example house design for n = 3, m = 6. Of course, Alan wants to follow this custom to make sure he fits right in. However, there are so many possible designs to choose from. Can you tell Alan how many possible house designs there are? (Two house designs are obviously the same if they can be translated into each other just by rotation.)

Input

The input consists of: • one line with three integers n, m, and c, where – n (1 ≤ n ≤ 500) is the side length of every wall, i.e. every wall consists of n × n squares; – m (3 ≤ m ≤ 500) is the number of corners of the regular polygon; – c (1 ≤ c ≤ 500) the number of different colors. GCPC 2017 Problem B: Buildings 3

Output

Output s where s is the number of possible different house designs. Since s can be very large, output s mod (109 + 7).

Sample Input 1

1  3  1

Sample Output 1

1

Sample Input 2

2 5 2

Sample Output 2

 209728

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const ll mod = 1000000007;
ll pow_mod(ll x,ll n)
{
    ll ans = 1;
    while(n)
    {
        if(n%2==1)
        {
            ans *= x;
            ans %= mod;
        }
        n /= 2;
        x *= x;
        x %= mod;
    }
    return ans;
}
int main()
{
    ll n,m,c,i,ans = 0,x;
    scanf("%lld%lld%lld",&n,&m,&c);

    for(i=0;i<m;i++)
    {
        x = __gcd(i,m);
        ans += pow_mod(c,n*n*x);
        ans %= mod;
    }
    ans = ans * pow_mod(m,mod-2)%mod;
    printf("%lld\n",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdut_jk17_zhangming/article/details/82025110