ZOJ 1002:Fire Net(DFS+回溯)

版权声明:本文为博主原创文章,转载请注明出处 https://blog.csdn.net/wang_123_zy/article/details/82377384

Fire Net


Time Limit: 2 Seconds      Memory Limit: 65536 KB


Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample input:

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample output:

5
1
5
2
4

题意

大小为n*n的城市建造碉堡,要求碉堡建在‘.’位置,每两个碉堡不能在一行或一列,或者在一行一列的时候中间有‘X’隔开,问在这个城市中最多能建多少碉堡

思路

从左上角往右下角进行dfs,用一个check函数来判断当前位置是否可以建造碉堡,如果可以的话,将该位置做特殊标记。回溯寻找最大值

AC代码

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <limits.h>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <set>
#include <string>
#define ll long long
#define ull unsigned long long
#define ms(a) memset(a,0,sizeof(a))
#define pi acos(-1.0)
#define INF 0x7f7f7f7f
#define lson o<<1
#define rson o<<1|1
const double E=exp(1);
const int maxn=1e3+10;
const int mod=1e9+7;
using namespace std;
char ch[maxn][maxn];
int n;
int ans;
bool check(int x,int y)
{
    for(int i=x-1;i>=0;i--)
    {
        if(ch[i][y]=='%')
            return false;
        if(ch[i][y]=='X')
            break;
    }
    for(int i=y-1;i>=0;i--)
    {
        if(ch[x][i]=='%')
            return false;
        if(ch[x][i]=='X')
            break;
    }
    return true;
}
void dfs(int s,int sum)
{
    if(s==n*n)
    {
        ans=max(ans,sum);
        return ;
    }
    int x=s/n;
    int y=s%n;
    if(ch[x][y]=='.'&&check(x,y))
    {
        ch[x][y]='%';
        dfs(s+1,sum+1);
        ch[x][y]='.';
    }
    dfs(s+1,sum);
}
int main(int argc, char const *argv[])
{
    ios::sync_with_stdio(false);
    while(cin>>n&&n)
    {
        ans=0;
        for(int i=0;i<n;i++)
            cin>>ch[i];
        dfs(0,0);
        cout<<ans<<endl;    
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wang_123_zy/article/details/82377384