Unidirectional TSP—dp

问题描述:

Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Salesperson Problem (TSP) -- finding whether all the cities in a salesperson's route can be visited exactly once with a specified limit on travel time -- is one of the canonical examples of an NP-complete problem; solutions appear to require an inordinate amount of time to generate, but are simple to check. 

This problem deals with finding a minimal path through a grid of points while traveling only from left to right. 

Given an m*n matrix of integers, you are to write a program that computes a path of minimal weight. A path starts anywhere in column 1 (the first column) and consists of a sequence of steps terminating in column n (the last column). A step consists of traveling from column i to column i+1 in an adjacent (horizontal or diagonal) row. The first and last rows (rows 1 and m) of a matrix are considered adjacent, i.e., the matrix ``wraps'' so that it represents a horizontal cylinder. Legal steps are illustrated below. 


 

The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited. 

For example, two slightly different 5*6 matrices are shown below (the only difference is the numbers in the bottom row). 

 


The minimal path is illustrated for each matrix. Note that the path for the matrix on the right takes advantage of the adjacency property of the first and last rows. 
 

Input

The input consists of a sequence of matrix specifications. Each matrix specification consists of the row and column dimensions in that order on a line followed by integers where m is the row dimension and n is the column dimension. The integers appear in the input in row major order, i.e., the first n integers constitute the first row of the matrix, the second n integers constitute the second row and so on. The integers on a line will be separated from other integers by one or more spaces. Note: integers are not restricted to being positive. There will be one or more matrix specifications in an input file. Input is terminated by end-of-file. 

For each specification the number of rows will be between 1 and 10 inclusive; the number of columns will be between 1 and 100 inclusive. No path's weight will exceed integer values representable using 30 bits 

Output

Two lines should be output for each matrix specification in the input file, the first line represents a minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence of n integers (separated by one or more spaces) representing the rows that constitute the minimal path. If there is more than one path of minimal weight the path that is lexicographically smallest should be output. 
 

Sample Input

5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 8 6 4
5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 1 2 3
2 2
9 10 9 10

Sample Output

1 2 3 4 4 5
16
1 2 1 5 4 5
11
1 1
19

题意:

给你个二维数组,你可以从第一列第 i 行出发向下一行行走,但每次只能到达下一行的第 i 行或与它相邻的第 i-1或 i+1行(这里第 1 行与第 n 行看做是相邻的)。问怎么走才能使路径上数字和最小,先把路径输出出来,再把最小的和输出出来。

思路 / 方法:

假设你在第 j 列第 i 行,在第 j-1 列则有第 i-1,i,i+1行可以走到当前位置,为了使路径数字和最小,应该选择到达这三个位置是路径数字总和最短的一个走到当前位置,如果数字总和相同保留字典序较小的路径,另外两个就可以舍弃掉。dp[ i ][ j ] = min( dp[ i-1 ][ j-1 ] , dp[ i ][ j-1 ] , dp[ i+1 ][ j-1 ]) + k [ i ][ j ]。

代码:

#define N 12
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[N][10*N];//记录到达当前位置使,所走路径上的数字总和
int k[N][10*N];
int f[N][10*N];//记录路径
int l[10*N];
int n,m;
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1; i<=n; i++)
            for(int j=1; j<=m; j++)
                scanf("%d",&k[i][j]);
        for(int i=1; i<=n; i++)
        {
            dp[i][1]=k[i][1];//第一列路径上的数字
            f[i][1]=i;       //第一列的路径就是当前位置
        }
        int mi,flag;
        for(int j=2; j<=m; j++)
        {
            mi=0x3f3f3f3f;
            //下面就是 dp[i][j]=min(dp[i-1][j-1],dp[i][j-1],dp[i+1][j-1])+k[i][j]
            for(int i=1; i<=n; i++)
            {
                int d;
                if(i==1)
                {
                    d=i;
                    if(n>1&&dp[i+1][j-1]<dp[d][j-1])
                        d=i+1;
                    if(dp[n][j-1]<dp[d][j-1])
                        d=n;
                }
                else if(i==n)
                {
                    d=1;
                    if(n>1&&dp[n-1][j-1]<dp[d][j-1])
                        d=n-1;
                    if(dp[n][j-1]<dp[d][j-1])
                        d=n;
                }
                else
                {
                    d=i-1;
                    if(dp[i][j-1]<dp[d][j-1])
                        d=i;
                    if(dp[i+1][j-1]<dp[d][j-1])
                        d=i+1;
                }
                dp[i][j]=dp[d][j-1]+k[i][j];//保留最小的路径数字总和
                f[i][j]=d;                  //记录是从哪一行走到当前位置
                if(j==m&&dp[i][j]<mi)       //走到尽头时,记录下路径上数字最小的在哪一行
                {
                    mi=dp[i][j];
                    flag=i;
                }
            }
        }
        int d=dp[flag][m];
        for(int i=m; i>=1; i--)
        {
            l[i]=flag;//把路径存到 l 数组中,便于输出
            flag=f[flag][i];//寻找上一步的路径
        }
        for(int i=1; i<=m; i++)//输出路径
        {
            if(i!=m)
                printf("%d ",l[i]);
            else
                printf("%d",l[i]);
        }
        printf("\n%d\n",d);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lxxdong/article/details/81103742
TSP