冒泡排序 hdu 1040(水题)

As Easy As A+B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 72343    Accepted Submission(s): 30730


 

Problem Description

These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!

 

Input

Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.
It is guarantied that all integers are in the range of 32-int.

 

Output

For each case, print the sorting result, and one line one case.

 

Sample Input

 

2 3 2 1 3 9 1 4 7 2 5 8 3 6 9

 

Sample Output

 

1 2 3 1 2 3 4 5 6 7 8 9

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
using namespace std;

int main()
{
    int n,m;
    int a[1010];
    while(cin >> n){
        while(n--){
            cin >> m;
            int i,j,t;
            for(i = 0;i < m;i++)
                cin >> a[i];
            for(i = 0;i < m;i++)
                for(j = 0;j < m-i-1;j++)
                    if(a[j] > a[j+1]){
                        t = a[j];
                        a[j] = a[j+1];
                        a[j+1] = t;
                    }
            for(i = 0;i < m;i++){
                cout << a[i] << (i==m-1?'\n':' ');
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42754600/article/details/81142011