POJ1731 Orders 【全排列】

Orders

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions:11656   Accepted: 6920

Description

The stores manager has sorted all kinds of goods in an alphabetical order of their labels. All the kinds having labels starting with the same letter are stored in the same warehouse (i.e. in the same building) labelled with this letter. During the day the stores manager receives and books the orders of goods which are to be delivered from the store. Each order requires only one kind of goods. The stores manager processes the requests in the order of their booking. 

You know in advance all the orders which will have to be processed by the stores manager today, but you do not know their booking order. Compute all possible ways of the visits of warehouses for the stores manager to settle all the demands piece after piece during the day. 

Input

Input contains a single line with all labels of the requested goods (in random order). Each kind of goods is represented by the starting letter of its label. Only small letters of the English alphabet are used. The number of orders doesn't exceed 200. 

Output

Output will contain all possible orderings in which the stores manager may visit his warehouses. Every warehouse is represented by a single small letter of the English alphabet -- the starting letter of the label of the goods. Each ordering of warehouses is written in the output file only once on a separate line and all the lines containing orderings have to be sorted in an alphabetical order (see the example). No output will exceed 2 megabytes. 

Sample Input

bbjd

Sample Output

bbdj
bbjd
bdbj
bdjb
bjbd
bjdb
dbbj
dbjb
djbb
jbbd
jbdb
jdbb

Source

CEOI 1999

扫描二维码关注公众号,回复: 2865387 查看本文章

问题链接:POJ1731 Orders

问题简述:对于输入的字符串,按字典顺序输出它的所有全排列

题解:先进行排序,使得初始字符串字典序最小(使用sort函数),再使用STL全排列库函数next_permutation就可以轻松解决

AC的C++程序:

#include<iostream>
#include<algorithm>
#include<string>

using namespace std;

int main()
{
	string s;
	cin>>s;
	sort(s.begin(),s.end());//排序使得字符串字典序最小
	do{
		cout<<s<<endl;
	}while(next_permutation(s.begin(),s.end()));
	return 0; 
} 

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/81673636