[贪心+并查集] [kuangbin带你飞]专题五 并查集 G - Supermarket

G - Supermarket

 

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ  x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
 For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 
Input
A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.
Output
For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.
Sample Input
4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10
Sample Output
80
185
Hint
The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.


贪心,最大的先卖,当天不行就往前推

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
int vis[10005];
struct node
{
	int p, t;
} a[10005];
bool cmp(node x, node y)
{
	return x.p > y.p;
}
int main()
{
	int n;
	while (scanf("%d", &n) != EOF)
	{
		memset(vis,0,sizeof(vis));
		for (int i = 1; i <= n; i++)
		{
			scanf("%d%d", &a[i].p, &a[i].t);
		}
		sort(a + 1, a + n + 1, cmp);
		int ans = 0;
		for (int i = 1; i <= n; i++)
		{
			int k = a[i].t;
			while (vis[k])
			{
				k--;
			}
			if(k==0) continue; //边界要注意
			vis[k] = 1;
		    ans += a[i].p;
		}
		printf("%d\n", ans);
	}
}

也可以用并查集进行优化,不用一天天向前推,可以跳着走

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
int pre[10005];  //因为城市可以很少,而天数可以很大,所以单开数组
struct node
{
	int p, t;
} a[10005];
bool cmp(node x, node y) //价值大的先卖掉,最好是保质期最后一天卖掉
{
	return x.p > y.p;
}
int find(int x)  //正常路径压缩
{
	if(pre[x]!=x) pre[x]=find(pre[x]);
	return pre[x];
}
void init()  //初始化
{
	for(int i=0;i<=10003;i++) pre[i]=i;
}
int main()
{
	int n;
	while (scanf("%d", &n) != EOF)
	{
		init();
		for (int i = 1; i <= n; i++)
		{
			scanf("%d%d", &a[i].p, &a[i].t);
		}
		sort(a + 1, a + n + 1, cmp);
		int ans = 0;
		for (int i = 1; i <= n; i++)  //如果此物品的最大一天保质期没有可,就找他的父节点用
		{
			int d=find(a[i].t);
			if(d==0) continue;   //边界判断,很重要,要是第一天用过了,他的父亲就是0,刀客0就不能再走了,不可能在卖掉此物品,直接continue
			pre[d]=d-1;    //要是能走,,这个点就被用掉了,他的父亲变成了前一天
		    ans += a[i].p;
		}
		printf("%d\n", ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/81039841